Creating Charts in
MS Excel
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CHARTS AND THEIR SIGNIFICANCE

A chartis a graphical representation of data. Charts make it a lot more easier for us to analyze
and interpret data. Comparisons and trends can also be shown at a glance with the help of
charts.

Observe the following figures to have a glimpse of the usefulness of charts.

Data performance of some students Chart showing performance data graphically

In first Fig, you, have to go through the entire data to compare the performance of students
and find out who has done the best and worst of them all.
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In second, just by looking at the chart, you can compare the performance of the students and
instantly know who put up the best performance.
There are many advantages of charts. Some of the advantages are :

Charts present data and information in an attractive manner.

Charts present data and information in a compact manner.
Charts are easier to understand and compare.

Charts have along lasting effect on the mind than a simple data statement.

COMPONENTS OF A CHART

The various components of a chart are shown in the given figure :

Data Series

Chart Title

Chart Area
Gridlines <

Data Labels
Y-Axis

Legends

Plot Area

|

Axis Titles X-Axis

Chart Title : Chart title is generally placed at the top of a chart. It helps a user to know the
purpose of a chart.

Chart Area: The chart areaincludes all objects and elements in a chart.

Plot Area : The plot area is the part of the chart area where your data is actually plotted. The
plot are of a chart is bounded by two axis (x-axis and y-axis) in a 2-D chart. In a 3-D chart the
plotareaisbounded by walls (vertical areas) and floor (base area).
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X-Axis: The x-axis is the horizontal axis that bounds the plot area of a chart. It is generally
used to display data categories and therefore also known as the category axis.

Y-Axis: The y-axis is the vertical axis that bounds the plot area of a chart. The y-axis is
generally used for showing data values and therefore also known as the value axis.

Axis Titles : The axis titles are the titles given to the x and y axis of a 2-D chart and the x, y and
zaxis of a3-D chart.

Data Series : A data series is a set of values on the worksheet that you want to plot in the form
of a chart. Each data series is given a unique colour or pattern in the chart that makes it easier
to distinguish between them visually.

Legends: Alegend is a key that identifies a data series. It describes a data series represented
in a particular colour on the chart.

Data Labels : The data label is a text or label that provides additional information about a
data marker (part of a chart that shows a particular data item of a data series).

Gridlines : The gridlines are the horizontal and vertical lines drawn on the plot area. The
gridlines make it easy for a person to read the chart. You can, however, hide the gridlines, if
you so desire.

DIFFERENT TYPES OF CHARTS

Excel provides us with a large variety of charts to represent data in a number of ways. Let us
learn about some common types of charts that are frequently created in MS Excel.

Chart Type Its Description

A Column chart is a commonly used chart type to
display in the form of vertical bars. A column chart
shows data changes over a period of time. It is ideal
when you want to compare data items from a single
category of data. Categories are shown along the x-
axis and values along the y-axis.

COLUMN

Like a column chart, a Bar chart also shows
comparisons among individual items. However, in a

BAR

bar chart, categories are shown along the y-axis and
values along the x-axis.
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DOUGHNUT PIE LINE

AREA

Bl Activity

A Line chart shows how data changes over a period of
time. In a line chart, each data item is represented by a
dot called a data marker.

A Pie chart represents the distribution or proportion
of each data item over a total value (represented by the
whole circle or pie). This chart is used for showing
data from one data series only.

A Doughnut chart shows the relationship of parts to a
whole. It is like a pie chart but can plot more than one
dataseries.

An Area chart shows the magnitude of change in data
over a period of time. It is similar to the line chart
except that the area below the plotted line is filled to
indicate magnitude.

State whether these statements are 'True' or 'False':

1. The horizontal axis is also called the x-axis or the category axis.

Legends are data values that you want to plot in the form of a graph.

2
3. Thechartareaisa part of the plot area of a chart.
4

The Area chart shows the magnitude of change in data over a period of time.
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CREATING A CHART

Creating a chart is very easy in MS Excel. The Insert tab contains all the options that help us to

create and modify charts. The steps to create a chart are as follows:

1.
2.

10.

Select the data that you want to plotin chartincluding the headings.

Click on the Insert tab. In the Charts group, click on a desired chart category button
(Column, Line, Pie, Bar and so on).

From the drop down list that appears select the desired chart type.

.... The chart will appear in the worksheet.

As the chart gets inserted, the Chart Tools category will appear showing three
contextual tabs- Design tab, Layout tab and format tab.

Column Chart inserted in the worksheet
Click on the Design tab.
From the Chart Layout group. Select a layout for your chart. (We have selected LayoutI
from the group.
From the Chart Style group select a style for the chart.
Move the chart manually anywhere in the worksheet by dragging it with the mouse.
Resize the chart manually by dragging if from any of the eight resizing handles.
(Dragging from corner handles will resize the chart proportionally).
To move the chart to another worksheet or to put it on a separate chart sheet, click the
Move Chartbutton in the Location group. The Move Chart dialog box opens.
a. To create a new chart sheet select the New Sheet option button and enter a name for
the chart sheet.
b. To move the chart to another worksheet, select the Object in option button and then
select the worksheet from the drop down menu.

ﬁq»Qa\<b/
e .
S, > @
B\ > &

eeIE) o



11. Click anywhere outside the chart to finish.

Move Chart Dialog Box
MODIFYING THE CHART

After inserting the chart we can edit and format its various elements as per our requirement.
The options given in the Design, Layout and Format tabs (under the Chart Tools category)
help us tomodity the chart and its elements.
Changing the Chart Type
We can easily change the chart from one type to another, like from a line chart to a Column
chart. Follow these steps to change the chart type:

1. Clickanywherein the chart to selectit.

2. Click on Design tab under Chart Tools.

3. Click on the Change Chart Type button.

Chart Types Subtypes

Change Chart Type Dialog Box

... The Change Chart Type dialog box opens.

4. Intheleftpane, select the Chart type and in the right pane, select the Chart subtype.
5. Click on the OK button.

... The chart type will change.
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ﬂ Remember

" The chart Tools contextual tabs will be displayed only when you have selected the chart. They will disappear once
the chart is deselected.

Adding the Chart Title
A chart title gives an idea about the topic of the chart. We can add a title to our Excel chart to
make it more meaningful.

1. Select the chart to which you want to add the chart title.

2. Under the Chart Tools click on the Layout tab.

3. Click onthe Chart Title button.

Adding the Chart Title

.... Adrop-down menu appears displaying options that specify how the chart title will
be displayed on the chart.

4. Selectanoption (Above Chartin this case).
. Atextbox containing the text "Chart Title" Will be added to the chart.
5. Type toreplace the textin the text box with the text of the chart title.

ﬂ Remember

¥ The Above Chart option from the drop-down menu will first resize the chart and then add a title above the chart
area.

Addingthe Axis Title

Adding an Axis title to the chart helps the user to know what each axis represent. The axis
title can be added to both the horizontal axis (X-axis) and the vertical axis (Y-axis) of the chart.
Follow these steps to add the axis title in chart.

1. Click onanempty area of the chart to select it.

2. Click onthe Layouttab under Chart Tools category.

3. Click on the Axis Titles button.



Adding Title to X-axis
.... Adrop-down menu shows two options.
a. Primary Horizontal Axis Title for adding a horizontal axis title.
b. Primary Vertical Axis Title for adding a vertical axis title.
4. Pointto the required option and select the Title Below Axis option from the submenu.
... Atextbox containing the text "Axis Title" will be added below the axis.

5. Replace the textin the text box with the text of the axis.
A

i[ ;) | Remember

f

¥ Using the Layout tab, the position of the Legends can be changed. The data table and data labels can be added to
existing charts.

LAYOUT TAB COMMANDS

Following table lists some more command buttons of the Layout tab and what they help us to
do.

Command button Its Function

Chart Elements Helps you to select a particular chart element. Click on the
drop down arrow and select an element from the list.

Format Selection Produces a dialog box to allow you to format a selected chart
element.

Picture Allows you toinsert a picture on the chart.

Shapes Allows you to insert a shape on the chart.

Text Box Allows you to insert a text box on the chart.

Chart Title Allows you to add or remove a chart title or charges its
position.
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Axis Titles Gives you options to add, remove or position the axes titles.

Legend Gives you options to add, remove, or position the chart
legends.

DataLabels Gives options to show actual data values with the data series.

Data Table Addsadatatable to the chart.

Axes Gives options to change the formatting and layout of the
axis.

Gridlines Helps to show/hide gridlines on the chart.

TIP! You can also select individual chart elements manually by clicking on them in the chart. The name of the
selected element will automatically appear in the chart elements box.

FORMATTING THE CHART

We can change the formatting of the individual chart elements like Chart Area, Chart Title,
Plot area, Legends, Data series, Axis titles and Data labels and so on using the
commands/options given in the Chart Tools Format tab. The general steps to format a chart
elementare as follows:

Chart Elements Button Shape Styles  Options to format Shape Styles Options to format chart text

Command buttons in the Chart Tools Format Tab

1. Click on the chart element that you want to format. (You can also select it from the chart
elements box in the Current Selection group).

2. To apply a shape style to the selected elements, go to the Shape Styles group, scroll
through the styleslist and then click to select a desired style.

3. To fill a background colour in the selected elements click on the Shape Fill button and
from the drop down menu, select a desired colour.

OR

You can also use options given in the Shape Fill button drop down menu to fill a picture
or texture in the element.

4. Similarly, you can use the Shape Outline and the Shape Effects buttons to apply a
border and effect to the selected chart element respectively.
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5. To apply a WordArt style to the text inside the selected chart elements, go to the
WordArt Sytle group and click on the More button. Select the Word Art Style that you
like from the list displayed.

6. You can use the Text Fill button to fill text in the selected chart elements with a colour,
picture, gradient or texture. The Text Outline and Text Effects buttons can be used to
apply an outline style and effect to the text of the selected chart elements, respectively.

USING GOAL SEEK

Goal seek is a wonderful feature for fixing a specific result for one cell by adjusting a value in
another cell. Follow the given steps:
= Enter datainaworksheet Calculate total and percentage as shownin figure.
= Select the Data tab and click on the What-if-Analysis button in Data tools group. The
select Goal seek option. The Goal seek dialog box will appear on the screen.
= InSet cell : text box, define the cell address E6. on which the goal seek is a to be applied.
In this box, always refer the call that contains formula.
= Typethenew value 350 as aresultin To Value: text box. Press the Tab key.

Using Goal Seek

Goal Seek Dialog Box
= Click on the cell D6 in a worksheet. The address will appear in the By Changing Cell :
Textbox Click on OK button.
= The Goal seek status dialog box appears on the screen displaying the target value 150
and Current value 150. Click OK.
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= Observe the change in cell D5. The number will change according to percentage you
have defined.

Bl Activity

Write answer of the following questions in the blanks :

1. Which tab contains the options to create charts in MS Excel?

2. After creating chart, can you change it into another type of chart?
3. Which Tab category is displayed when you select a chart?

4. Using which tab can you change the title of a chart?

@
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= Chartisa powerful tool in MS Excel for presenting data in an easy to understand manner.

= Various types of charts can be used to represent selected data from a worksheet but any type of
chart has a specific purpose for which it can be used.

= [tisvery easy to create any type of chart using the command buttons given in the Charts group of
the Insert tab.

= After creating a chart you can move it or change its size by dragging with the mouse.
= You can select different components of a chart by clicking on them with the mouse.

= When a chart or chart component is selected, three new tabs- Design, Layout and Format appear
under the Chart Tools. These tabs contain commands to allow you to work with a chart and its
different components.

m Goal Seek is a wonderful feature for fixing a specific result for one cell, by adjusting a value in
another cell.

m Category axis The axis in an Excel chart along which data categories are plotted.

= Value axis . Theaxisin an Excel chart along which data values are plotted.
m Legend . Alegend contains a list of data series appearing in the chart and the colour of
their appearance.
m Chart . Graphical representation of data where data is represented by graphic
symbols.
m Columnchart : Achartwhere dataitems are shown as equidistant columns of varying heights.
m Linechart . Atype of chart used for showing variation in data over a period of time.
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(CHAPTER
Check-Up

A. Tick (V') the correct answer.

1.

Which of these is not a type of chart in MS Excel?

(a) Pie chart (b) Bar chart (c) Data chart
The plot area of a chart liesin the :
(a) Chartarea (b) Chart title (c) Legends
The vertical and horizontal lines in the plot area are called:
(a) Chart lines (b) Gridlines (c) Plot lines
What is used to represent a Data series?
(a) X-axis (b) Y-axis (c) Legends
What informs us about the topic of a chart?
(a) Data series (b) Axis title (c) Chart title
Which tab contains options to format a chart?

(a) Datatab (b) Format tab (c) Home tab

B. Fillinthe blanks with the help of given hints.

1.

2
3
4.
5

is an effective way to display data in pictorial form.

The x-axis is also known as the axis.

The vertical axisin a chartis also known as the

The of the chart gives you an idea of its topic.

The charts are useful to show data changes over a period of time or for
comparison.

You can resize a chart by it from its resizing handles.

HINTS: Y-axis, Chart, Dragging, Category, Linechart, Title

C. Write 'T' for true statements and 'F' for false statementsin the D .

S U1 N W N

Inabarchart, categories are organized along the vertical axis.

The pie charts are used to represent data from two or more data series.
Legends in a chart represent the actual data values.

Each data series is given a unique colour or patternin a chart.

The chart area is always a part of the plot area.

Chart styles group is present in Design tab of the Ribbon.
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D. VeryShort Answer Questions.
1. Whichtabin Excel 2010 contains the Charts group?

2. How many contextual tabs appear on the ribbon when a chart is selected?

3. Name any two types of column chats present in Excel.

4. Define Goal seek.

E. Short Answer Questions.
1. When do you use a pie chart?

2. Whyisthe horizontal axis called the category axis?

3 Whatis meant by a data series?

F. LongAnswer Questions.
1. Whatis the significance of representing data through charts?

2. Distinguish between a column chart and a bar chart.

3. What do you understand by legends and data series?

4. Howis the chart area different from the plot area?

5. Writein brief, the steps to add a title to a chart.

6. Whatis the use of the Chart Elements button in the Layout tab?




Practical 1: Creating a Column chart from the given data to compare the runs scored by all batsman in each
match.

1. Selectthe data A1:D4.
2. Click ontheInserttab.

3.

Click on the Column arrowhead button and select the 3-D column subtype.
4,

From the Chart Layout, select the desired layout for the chart.
..... The required column chart will be created.

Practical 2 : Creating a chart to represent data pictorially.

1. Prepare a worksheet as shown alongside. Save it by any name as you like.

l\

2. Create a 3-D stacked column chart showing a comparison of how the rates of food grains have
risen over the previous three years.

3. Createaline chart to show the fluctuation in the food grain price over period of three years.
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